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Unit – I Introduction to MS – Word 

 
 
Structure 

1.0 Objective 
1.1. Creating and saving documents 

1.1.1. Page setup 
1.2. Formatting Text 

      1.3. Header and footer 
      1.4. Hyperlink and Book marks 
      1.5. Inserting and editing pictures 
      1.6. Creating tables 

      1.6.1. Inserting, deleting and merging rows and column 
     1.7. Mail merge 
     1.8. Printing document 

1.9.Summary 
1.10. SAQ 

_______________________________________________________________ 
 
1.0.Objective 
Microsoft word is part of Microsoft’s office suite of software. It is a word 
processor, which is world’s leading word processing application. The primary 
objective is to enable students to create and edit document, save it to view or 
edit later and print document and many more features. 
 
Microsoft Word 2007 has a completely redesigned user interface.  The 
standard menus along the top have been removed and replaced with a series of 
toolbars Microsoft calls “The Ribbon.” The tool bars are changed using tabs at 
the top and try to automatically adjust themselves to the content you are 
working with.  If you select an image it will automatically switch to the 
picture tools.  The new layout seems to offer easier access to most of the 
features of Word allowing for more complex documents to be created quicker. 
 
1.1. Creating and saving document 

The first thing most people will need to relearn is where to go to 
open a document, create a new one, save your document and print.  
Clicking the Office logo at the top left of the screen will provide 
most of the items formerly found under the file menu including 
those listed above.   Beside the logo you also will find a disk icon 
to save your document as well as the undo and redo buttons. 
 

To create a new blank document: 
 

1. Click the Microsoft Office button. 
2. Select New. The New Document dialog box appears. 



Computers                                                                                Prak-Sastri 2nd Year 

Directorate of Distance Education, R.S.Vidyapeetha, Tirupati.                        2 
 

3. Select Blank document under the Blank and recent section. It will be 
highlighted      by default. 

4. Click Create. A new blank document appears in the Word window. 
Start a document from a template 

To use a template as a starting point, do one of the following: 

1. In Microsoft Office Word 2010, 2013 or 2016, click File, and then 
click New.  In Microsoft Office Word 2007, click the Microsoft Office 

Button  , and then click New. 
2. Under Templates, do one of the following: 

 If you are using Microsoft Office Word 2007, click Installed 
Templates to select a template that is available on your 
computer. If you are using Microsoft Office Word 2010, look 
in Available Templates 

 In Microsoft Office Word 2007, click one of the links 
under Microsoft Office Online. In Microsoft Office Word 
2010, click Office.com Templates. In Microsoft Office Word 
2013 and 2016, all available installed templates are shown 
when you click File, and then click New and additional 
templates can be discovered by using the Search for online 
templates search box. 

3. Double-click the template that you want. 

To save a copy of your file, do the following 
 

1. Click the Microsoft Office Button, and then click Save As, or press 
CTRL+S. In the File name box, enter a new name for the file. 

2. Click Save. 
 

Note: If you don't see the Microsoft Office Button, click Save As on the File 
menu. 

 Opening a file (CRTL+N) 

1. Click the Microsoft Office Button, and then click Open. 
2. In the File of type list, click OpenDocument Text. 
3. Click the file you want to open, and then click Open. 

 Page layout 
The Page Layout Tab lets you control the look and feel of your 
document in Microsoft Word, a global design to your document by 
using one of the available themes and colour schemes. Changing the 
document orientation, page size, margins, indentation, line spacing and 
paragraph settings can be performed. 
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 Themes: The themes section provides a 
quick way to format your document.  By choosing a theme 
you will have a set colour scheme, font combinations, and 
effects.  You can choose one of the provided themes, 
modify a provided them or create your own.  Be aware that 
changing your theme after creating a document may require 
you to reformat some items as themes also include some 
layout options. 

 

1.1.Page Setup: Page setup provides you with the tools to change margins, 
size, orientation, columns, breaks, line numbers and hyphenation in the 
document.   

 
 

 

 

 Page Background: The page background section allows you to change the 
background colour of the document, watermark and draft or confidential 
document or add borders to your document. 
  
 

 

 
 

 Paragraph: The paragraph section in the page layout tab allows changes to 
a paragraphs spacing and indentation. 
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 Arrange: The arrange section is also found in the image toolbar when an 
image is selected.  Here you can change an images position, how text 
moves around the image, the alignment, grouping and rotation or the 
image.  
 
 
 
 
 
 

1.2. Formatting Text 

Formatting text in Microsoft Word involves tasks like bolding the text, 
italicising it, and changing the font and size. The commands to perform all of 
these formatting tasks are found on the Home tab in the Font group. Select 
your text and then click on the required formatting button to see the effects. 

1.2.1. Setting font size 

1. Selecting Text 

The first step in formatting any amount of text or an entire document is 

selecting the portion of text that needs formatting. For formatting text, the 

following should be known 

 Boldface a section 
 Add italics 
 Underline 
 Change the colour 
 Change the font 
 Highlight 
 Cut/copy and paste 
 Add bullets 

To do any of this, you must first select the text that the formatting will be 

applied to within the document. Selecting text is easy and done in three easy 

steps. 
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1.      Move the cursor to the beginning of the text that you want to select.  
2.      Click and hold in the left button on your mouse.  
3.      Drag it over the text you want to select. It will highlight the selected text   
         in blue. Simply release the mouse button when you are finished  
         selecting text. 

If you want to select the entire document, simply click on the 'Home' tab 

and click 'Select' on the far right. You will then select 'select all'. This will 

highlight all your text for formatting. Also note that you can select objects or 

text with similar formatting as your selected text when clicking on 'Select.' 

Applying a Font 
You can apply a font to either an entire document or to certain portions 

of a document. The choice is yours. To apply a font, click on 
the Home tab. You'll see the toolbars, or groups. 

The type of font you're currently using will appear.   In the picture 
above, the current type of font is Calibri. The notation of (body) after Calibri 
lets the user know that it's the font used in the body of text, not in headers, 
footnotes, etc.   You can click on the arrow in that window to display other 
types of font available to use.  To change the type of font within a document 
or for the entire document, simply select the text to be formatted, then select 
your new font. It's really that easy. 

Note: You can also do all font formatting by selecting the arrow key beside 

the word Font, located directly above the document body. By clicking on this 

arrow, you can also alter character spacing. 

Changing Font Size 
Next to the type of font under the 'Home' tab is a box that states the 

size of font currently being used. Using the picture above, the font size is 
12. Once again, you can use the down arrow key to either enlarge or reduce 
the font size. To change the size of the font, simply select the text that you 
want to change, then select the new font size. You can change an entire 
document or just a portion. The choice is yours. You can also use the two 
uppercase A's beside the font size box to change the size of fonts you're 
currently using. Pushing the larger A will increase your font size by one for 
each time it's clicked. On the other hand, clicking the smaller A will decrease 
the font size by one for each time it's clicked. 
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Font Attributes 
As we discussed earlier, you may want to select text to either boldface, 

italicize, or underline a section of text. The boldface command in MS Word is 
represented by an uppercase, boldfaced B. Italics are represented by an 
uppercase, italicized 'I', and underline by an uppercase U with a line under 
it.   These button's are located directly below the font type window. To 
add italic, boldfaced or underlining to any portion of a text within a 
document, select the desired text, then click the appropriate button (ctrl +B for 
boldfaced, ctrl + I for italic, or ctrl + U for underline.)  

Next to the commands for boldfaced, italics, and underline, you'll see 
an 'abc' with a line through it. (abc) This is for strikethrough. When clicking 
on this button, it will put a line through any text you have selected. 

Next to the strikethrough command, you'll see 'X2'. This simply puts 
smaller text below the text line of the normal text.   This command was used 
when typing X2 into this course. X2 is just the opposite, putting smaller text 
above the text line. This makes creating footnotes easier than it had been with 
previous versions of Word.   

The uppercase A and lowercase A that are situated side by side allow 
you to change the case of selected text. You can change from lowercase 
to uppercase or vice versa , toggle tHeCaSe, or select other common 
capitalizations.  

1.2.2 Font Color 

Changing the font color is as simple as changing the font.   Look for 
the uppercase A with a black bar under it as pictured below. It's just to the 
right of the Aa that allows you to capitalize portions of text. Select your text, 
then click on the button to choose the colour you want to apply to the selected 
text. You can also highlight selected text. To the left of the font colour button, 
you'll see a lowercase 'ab' with a marker near it. It is highlighted in 
yellow. Simply select the portion of text you want to highlight, click the 
button, and select the colour of highlight that you want to apply. 

1.2.3. Formatting paragraph 

When you format paragraphs within a document, you can change the 
look of the entire document.   Formatting a paragraph allows you to change 
line spacing, indent lines, and alter all of your paragraphs or just a few so that 
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they look the way you want them. Many of the tools you can use to format 
your paragraphs will be located in the 'Page Layout' tab of the Ribbon in the 
'Paragraph' group. 

i) Aligning text 

As with all word processing programs, you can either left, right, center 
or justify your text. You can either do one of these things to a portion of text 
or to the entire document. 

For example the below text which is aligned to the left and center 

This is text that is aligned to the right. 

This text is centered. 

Justified text:  it is aligned between the left and right margins, adding space 
between letters if necessary. It gives the document a clean look. The buttons 
or commands for aligning text are located under the 'Home' tab above 
the 'Paragraph'. 

The Home tab consists of the left alignment button beside it is the center, 
then right, and then justify.   To use these, simply select the text you want to 
align, and click on the appropriate button. 

ii) Aligning line spacing 

Line spacing Adjusting line spacing changes the amount of space 
between lines of text. Line spacing can be single, 1.5, double; multiple or you 
can choose your own size. Adjusting line spacing  

 Select the text that you want to adjust the line spacing on. If you want to 
change the whole document, choose Select then Select All from the 
Editing group 

 Click the arrow button to the right of the Paragraph group to open the 
Paragraph dialog box 

 Select the Indents and Spacing tab 
 Click on the down arrow below line spacing. Select a new size   

 Click OK. 
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1.3.Headers and Footers 

       Header and footer can make your document look professional and 
polished by utilizing the header and footer sections. The header is a section of 
the document that appears in the top margin, while the footer is a section of 
the document that appears in the bottom margin. Headers and footers 
generally contain information such as page number, date, and document 
name.  

 
To insert a header or footer: 

 Select the Insert tab. 

 Click either the Header or Footer command. A menu appears 
with a list of built-in options you can use. 

 Left-click one of the built-in options, and it will appear in the 
document. 
 
OR 

 Left-click Blank to select it. 

 The Design tab with Header and Footer tools is active. 

 Type information into the header or footer. 

To insert the date or time into a header or footer: 

 With the header or footer section active, click the Date & 
Time command. 

 Select a date format in the dialog box that appears. 

 Click OK. The date and time now appear in the document. 

Other header and footer options 

There are many other header and footer options you can use to design 
these sections of your document. From the Header and Footer Tools 
Design tab, you can see all of your design options.  
 

1.3.1. Page numbering 
 

1. On the Insert tab, in the "Header & Footer" group, click Page Number. 

2. Click Top of Page, Bottom of Page, or Page Margins, depending on 
where you want page numbers to appear in your document. 
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3. Choose a page numbering design from the gallery of designs. 

4. On the Design tab, in the "Options" group, choose Different First 
Page. 

Page numbering in header and footer can be set for alignment similar 
to that of a paragraph like center/left/right based on the requirement which is 
available in the header and footer options 

1.4. Hyperlink and Book Marks 
1.4.1. Hyperlink 

            A hyperlink is a piece of text or an image in an electronic document 
that can connect readers to another portion of the document or a different 
webpage. In addition, a hyperlink can be used to connect to and open an email 
client window.  
 
            Have you noticed the active links on webpages that allow you 
to jump from one page to another? You just used one to open this lesson. 
These are called hyperlinks. You can use these in electronic versions of your 
Word documents, just like you do in webpages. In this lesson, you will learn 
the basics of working with hyperlinks, including how to insert and remove 
them in your Word document. 

To insert a hyperlink: 

 Select the text or image you want to make a hyperlink. 

 Select the Insert tab. 

 Click Hyperlink in the Links group. The Insert Hyperlink 
dialog box appears. If you selected text, the words will appear 
in the Text to display:field at the top. 

 Type the address you want to link to in the Address: field. 

 Click OK. The text or image you selected will now be a 
hyperlink. 

To make an email address a hyperlink: 

 Type the email address. 

 Highlight the text, and select the Insert tab. 
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 Click Hyperlink in the Links group, and the Insert Hyperlink 
box appears. 

 On the left of the box where it says Link to: click Email 
Address. 

 The Insert Hyperlink box will change to the one shown 
above. 

 Type the email address you want to connect to in the Email 
Address box, then click OK. 

To remove a hyperlink: 

 Select the hyperlink you want to deactivate. 

 
 Select the Insert tab. 

 Click Hyperlink in the Links group. The Edit Hyperlink 
dialog box appears 

 Click Remove Link. 

1.4.2. Book mark 

       The bookmarks are the HTML elements that mark some locations in a 
document to enable the browsers to visit these locations immediately by 
activating so-called links. The bookmarks usually mark the headers of 
chapters and sections, the citations, the index entries etc. 

A bookmark in Word works like a bookmark you might place in a 
book: it marks a place that you want to find again easily. You can enter as 
many bookmarks as you want in your document or Outlook message, and you 
can give each one a unique name so they’re easy to identify. 

To add a bookmark, you first mark the bookmark location in your 
document. After that, you can jump to the location or add links to it within 
your document or Outlook message. You can also delete bookmarks from a 
document or Outlook message. 

Bookmark the location 

1. Select text, a picture, or a place in your document where you want to insert a 
bookmark. 

2. Click Insert > Bookmark. 
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3. Under Bookmark name, type a name and click Add. 

Note: Bookmark names need to begin with a letter. They can include both 
numbers and letters, but not spaces. If you need to separate words, you can 
use an underscore(_). For examplefirst_heading 

Go to the bookmarked location 

After creating your bookmarks, you can add links to them within your 
document or jump to them at any time. 

Jump to a bookmark 

Type Ctrl+G to open the Go To tab in the Find and Replace box. Under Go 
to what, click Bookmark. Enter or select the bookmark name, and then 
click Go To. 

 

Link to a bookmark 

You can also add hyperlinks that will take you to a bookmarked location in 
the same document. 

1. Select the text or object you want to use as a hyperlink. 
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2. Right-click and then click Hyperlink  . 
3. Under Link to, click Place in This Document. 
4. In the list, select the heading or bookmark that you want to link to. 
5. Click OK.. 

Delete a bookmark 

1. Click Insert > Bookmark. 
2. Click either Name or Location to sort the list of bookmarks in the document. 
3. Click the name of the bookmark you want to delete, and then click Delete. 
4. If you have inserted a hyperlink to the deleted bookmark, right-click the 

linked text and then click Remove Hyperlink. 

1.5. Inserting and Editing pictures  

Pictures can be added to Word documents and then formatted in various ways. 
The picture tools in Word 2007 make it easy to incorporate images into your 
documents and modify these images in innovative ways.  

 

Inserting and modifying pictures  
To insert a picture: 

 Place your insertion point where you want the image to appear. 

 Select the Insert tab. 

 Click the Picture command in the Illustrations group. The Insert 
Picture dialog box appears. 
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 Select the image file on your computer. 

 
 
 Click Insert, and it will appear in your document. 

To wrap text around an image: 

 Select the image. 

 Select the Picture Tools Format tab. 

 Click the Text Wrapping command in the Arrange group. 

 
 
 Left-click a menu option to select it. In this example, we 

selected Tight. 
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 Move the image around to see how the text wraps for each 
setting. 

 The Position button has predefined text wrapping settings. The 
Position button is located to the left of the Text Wrapping 
button. 

 Click the Position button, and a drop-down list of text 
wrapping options will appear. Hover over an option to see 
what it does. 

To crop an image: 

 Select the image. 

 Select the Format tab. 

 Click the Crop command. The black cropping handles appear. 

 
 Left-click and move a handle to crop an image. 

 Click the Crop command to deselect the crop tool. 

 

1.6. Tables 

A table is made up of rows and columns. The intersection of a row and 
column is called a cell. Tables are often used to organize and present 
information, but they have a variety of uses as well. You can use tables to 
align numbers and create interesting page layouts. 

1.6.1. Creating Table, inserting and deleting rows and columns 

Creating tables  

Table can be easily made in MS Word. The following is the procedure to 
create table.  
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Click the New File icon to create a new document if necessary. To Create a 
Table: 

 Click the Insert tab on the Ribbon  
 Click the Table button 
 Select Insert Table 
 Click the arrows to select the desired number of columns 
 Click the arrows to select the desired number of rows  
 Click OK 

Formatting a Table: Using Microsoft Word you are able to format a table by 
changing table lines and colors, shading tables, adjusting row and column size 
as well as alignment. 

To Shade the Cells/Table: 

 Position your cursor in the table  
 Click the Layout tab on the Ribbon 
 Click the Select button in the Table group  
  Choose the item you wish to format  
 Click the Design tab on the Ribbon  
 Click the Shading button  
 Select a shading color. 

To Adjust the Line Style of a Cell/Table: 

 Position your cursor in the table  
 Click the Layout tab on the Ribbon  
 Click the Select button in the Table group 
 Choose the item you wish to format  
 Click the Design tab on the Ribbon 
 Select the Line Style drop-Down Arrow  
 Select a style  
 Click your mouse in the table where you want to apply the line style to 
  Press ESC key on the keyboard when you are finished applying the 

style. 
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Inserting, deleting and merging rows and columns  

a) To Insert a Row: 

 Position the cursor in the table where you would like to insert a row  
 Select the Layout tab on the Ribbon 
 Click either the Insert Row Above or the Insert Row Below button in 

the Rows & Columns group 

b) To Insert a Column 

 Position the cursor in the table where you would like to insert a 
column  

 Select the Layout tab on the Ribbon 
 Click either the Insert Columns to Left button or the Insert Columns to 

Right button in the Rows & Columns group 

c) To Delete a Row 

 Position your cursor in the row that you would like to delete  
 Select the Layout tab on the Ribbon  
 Click the Delete button in the Rows & Column group  
 Select Delete Rows  

d) To Delete a Column 

 Position your cursor in the column that you would like to delete  
 Select the Layout tab on the Ribbon  
 Click the Delete button in the Rows & Column group  
 Select Delete Columns 

e) To Merge Cells in a Table  

 Select the cells that you would like to merge in the table 
 Click on the Layout tab on the ribbon 
 Click the Merge Cells button in the Merge group 

Deleting table 

Keep in mind that deleting the table deletes all its contents as well. 
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 Click the mouse inside the table. The Table Tools appear. 
 If the Layout tab is not displayed, click to display it. 
 Choose Delete—Table. This command is located in the Rows & 

Columns group on the Layout tab. 

1.7 Mail merge 

Mail merge is a tool which allows you to create form letters, mailing 
labels and envelopes by linking a main document to a set of data or data 
source. It is the process of combining a list of data with a template. The mail 
merge process involves the following:  

The Main Document: Contains the text and graphics that are the same for 
each version of the merged document. 

Data Source: A file that contains the information to be merged into a 
document. For example, the names and addresses of the recipients of a letter.  

Mail Merge– Form Letters 

 Open Microsoft Word. Type the letter with all needed text and 
formatting leaving areas for the data source data blank (ex name, 
address…) 

 Click the Mailings tab 
 Click Start Mail Merge  
 Click Step by Step Mail Merge Wizard 

The Mail Merge task pane appears on the right of your screen. There 
are 6 steps           involved in Mail Merge. 

 Step 1 

 Click Letters for the document type 
 Click Next: Starting document  

Step 2 

 Click Use the current document under Select starting document 
 Click Next: Select recipients 
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Step 3 

 The recipients can come from either an existing Excel file, or Access 
table or you can create a new list. 

a) If Using an Existing List: 

 Click Use an existing list under Select recipients  
 Click Browse 
 Select the file 
 Click Open Mail Merge Recipients opens showing the names and 

addresses from your file 
 Click OK 
 Click Next: Write your letter  

b)To Type a New List: 

 Click Type a new list under Select recipients 
 Click Create 
 Click Customize Columns to modify the list of fields 
 Delete any unnecessary field names and/or add new ones  
 Click OK 
 Type records here hitting TAB to advance to the next field and to 

continue adding new records 
 Click OK 
 Click Save 

The recipients list will be saved as a separate file as a Microsoft 
Access file type. It is saved in the My Data Sources folder. It is 
recommended to save the file in this folder.  

 Click Next: Write your letter 

Step 4 

 Click the location in your document where the data from the mail 
merge fields need to be inserted   

 Click Address block…   
 Select the address elements you want included 
 Click OK 
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The field name will look like this: <> The Address block will insert 
the following fields including any necessary punctuation: First Name, 
Last Name, Company, Address 1, Address 2, City, State, Postal Code. 
If your fields do not match the ones listed above or you have 
additional fields, click More items… 

 Click on the field from the list  
 Click Insert 
 Click Close The field name will look like this - «First_Name»  
 Repeat this step until all fields have been inserted. Remember to put 

spaces and punctuation where needed.  
 Click Next: Preview your letters 

Step 5  

Here is where you can preview the first page with the fields filled in. 
Click Next: Complete the merge  

      Step 6  

 To Complete the Merge:  
 Click Print to send directly to the printer  
 Click Edit individual letters to create a new file Remember to save 

your document as you go. The next time you open your document and 
click on Step by Step Mail Merge, the data file will be attached 

Mail Merge – Labels  

 Open a new blank document  
 Click the Mailings tab  
 Click Start Mail Merge  
 Click Step by Step Mail Merge Wizard  

Step 1  

 Click Labels for the document type  
 Click Next: Starting document 
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Step 2  

 Click Label options under Change document layout 
 Choose the label style you are using  
 Click OK 
 Click Next: Select recipients 6  

Step 3  

 Click Use an existing list under Select recipients  
 Click Browse  
 Select the file that contains the names and addresses  
 Click OK  
 Click Next: Arrange your labels  

Step 4  

 Click in the first label box and click on either Address block or More 
items to insert the data fields 

 Click Update all labels to include the fields on all labels  
 Click Next: Preview your labels Step 5 Here is where you can preview 

the labels. Click Next: Complete the merge Step 6 Click Print to send 
directly to the printer OR Click Edit individual labels to create a new 
file 

1.8. Printing documents 

Once document is prepared now its time to print the document. Now let us 
see how to it can be done. 

1. Open or create a Microsoft Word document. To do so, click on the blue 
app with a white document icon and bold "W," then click on File in the menu 
bar at the upper-left of the screen. Click on Open... to open an existing 
document or New... to create a new one. 

 When you are ready to print, open the Print dialog box. 
 Click on File. It's in the menu bar at the upper-left of the screen or a tab at the 

upper-left of the window. 
 Click on print…..  The print dialog box will open. 
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 Select printing options. Use the selections in the dialog box to select such as 
number of copies to print, the size of paper to print on, the number of pagers 
to print per sheet, margins etc. 

 Click on print or ok.  
 
1.9.  Summary 
 
 Microsoft Word is an industry-standard and world’s most used word 

processing software. The program is used by educators, students, firstline 
workers, businesses, and enterprises. 

 
 While it is very common for schools, companies, and offices to have the 

program installed on their computers 
 
 Microsoft Word is also built and designed for personal use, and aims to help 

users view, edit, create, and share beautiful documents 
 

 
 To create a new blank document: 

 
 Click the Microsoft Office button. 
 Select New. The New Document dialog box appears. 
 Select Blank document under the Blank and recent section. 

It will be highlighted      by default. 
 Click Create. A new blank document appears in 

the Word window. 
 Start a document from a template 
 

 A hyperlink is a piece of text or an image in an electronic document 
that can connect readers to another portion of the document or a 
different webpage. 

 

 The bookmarks are the HTML elements that mark some locations in a 
document to enable the browsers to visit these locations immediately 
by activating so-called links. The bookmarks usually mark the headers 
of chapters and sections, the citations, the index entries etc. 

 
 Formatting text in Microsoft Word involves tasks like bolding the text, 

italicising it, and changing the font and size. The commands to 
perform all of these formatting tasks are found on the Home tab in the 
Font group. 
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 Header and footer can make your document look professional and 
polished by utilizing the header and footer sections. The header is a 
section of the document that appears in the top margin, while 
the footer is a section of the document that appears in the bottom 
margin 
 
 

 A table is made up of rows and columns 
 

 Mail Merge– Form Letters :Open Microsoft Word. Type the letter 
with all needed text and formatting leaving areas for the data source data 
blank (ex name, address…) 

 
1.10. SAQ 
 

1. What is MS-Word? 
2. List characteristics of MS-Word? 
3. Explain what is Text Wrapping? 
4. Explain what is WYSISYG? 
5. Briefly explain about page set up? 

 
 
 
 
 

 
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Unit – II MS – Power Point 

 
 
 
Structure 
2.0.Objective 
2.1.  Basics 
2.2. Creating Presentation 
2.3.  Menus and Tool bar 
2.4.  Opening a presentation 

2.4.1. Creating 
2.4.2. Inserting, Deleting and Saving Power point 
2.4.3. Copying new slide 

2.5.  Slide numbering 
2.6.  Animation and Transition   
2.7. Summary 
2.8. SAQ 

 

2.0. Objective 

       The main objective of this MS Power Point to make the student 
perfect in creating presentation, deleting unnecessary slides, slide numbering, 
inserting graph, picture, sound and video organization chart. Even assigning 
transition and timing for slide. How to print slide 

2.1. Basics 

  PowerPoint is the presentation program included in the 
Microsoft Office suite. With PowerPoint, you can create engaging 
presentations that can be presented in person, online, or as self-running 
slideshows. Your presentations can include graphics, audio and video clips, 
and links to external websites. PowerPoint 2007 has a different interface from 
previous versions of the program. 

2.1.1. Features of MS Power Point 

  PowerPoint is a highly innovative and versatile program that 
can ensure user a successful communication whether you’re presenting in 
front of potential investors, a lecture theatre or simply in front of your 
colleagues. Below are five features you should be using. They will improve 
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your presentation skills and allow you to communicate your message 
successfully. 

 Adding smart art 
 Inserting shapes 
 Inserting an image 
 Slide transitions 
 Adding animation 

2.2. Creating presentation 

To create a new presentation with PowerPoint 2007: 

 1. Launch PowerPoint 2007. The program will open up with a new blank 
presentation already created for you. 

 2. To save the presentation, click on the new Office button and choose Save 
(or click on the Save button in the Quick Access Toolbar). 

 3. Enter a file name for your new presentation and select a save location. 

 4. Click on Save. PowerPoint 2007 uses a different file format than previous 
versions of the program. However, you can save a copy. 

PowerPoint 2007 presentation that is backward-compatible with older 
versions of the program. To do this, click on the Office button and select Save 
As > PowerPoint 97-2003 Presentation. You should save often as your work 
on your presentation to avoid losing your changes. A quick way to save 
changes as you work is to use the keyboard shortcut Control + S. If you want 
to save a copy of your presentation with a different name, click on the Office 
button, choose Save As > PowerPoint Presentation and enter a different name 
in the File name field at the bottom of the Save As window.  

Another way to create a new presentation: By clicking on the Office button 
and choosing New. This will open the New Presentation window, where you 
will have the following options on the left side: 

• Blank and recent: click on Blank Presentation on the right to create a 
blank presentation with no formatting applied to it.  

• Installed Templates: these are the built-in presentation designs included 
with PowerPoint 2007. 
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• Installed Themes: similar to templates, but also include formatting such 
as colors, fonts and effects to give your presentations a consistent look. 

• Microsoft Office Online: these are templates you can download from the 
Microsoft website if you have an internet connection. Once you’ve 
chosen a template or theme, click on Create or Download. The formatting 
options included in the template or theme will be applied to the new 
presentation created by PowerPoint 2007 

2.3. Menus and Toolbar 

       menu’s  most common options are Properties, Inspect Document, Mark as 
Final and Run Compatibility Checker.  The properties option allows you to 
setup metadata for the document like Author, Title, keywords, comments and 
others.  Inspect Document will scan the document for any hidden data like 
comments and annotations, and any hidden collaboration data.  This is very 
useful when making a previously private document public.  It will help you 
find any comments or changes made previously that should not be made 
public.  Mark as Final will mark the document as a final copy and make it 
read only so changes cannot be made.   

The Home Tab 

 

The home tab the basic formatting tools found in PowerPoint 2007.  You will 
find five sections, Clipboard, Slides, Font, Paragraph and Editing.  Clicking 
the down arrow beside any of the icons here will drop down more options for 
that tool.  Each section except slides also contains an arrow in the bottom right 
corner which will open a window containing the options found in that section. 

Clipboard 
The Clipboard allows you to cut, copy, paste and copy 
formatting from one place to another.    
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Slides 
The slides section has tools to add new slides, change the 
layout of a slide, also reset or delete a slide.  Both the New 
Slide and Layout sections offer drop down menus with 
predefined slide layouts to use.   

 

Font 
The font section of the ribbon provides a 
section to handle the basic text formatting.  
Items such as bold, underline, strikethrough, 

highlight and font type can be changed here.  There are also some items like 
character spacing and text shadow.  Some items from this section and some 
items from the paragraph section are also available by highlighting text and 
moving your cursor slightly above the highlighted text.  This saves having to 
move your cursor all the way to the top of the screen for some common 
formatting items. 

 

Paragraph 
The paragraph section provides icons for 
bullets, lists, justify, line spacing, indents 
and text direction.  You can also access 
tools to align the text vertically within a 

section and add smartArt graphics. 

 

Drawing 
The main part of the 
drawing section gives 
you a large number of 
shapes, lines arrows and 

flowchart pictures.  The arrange icon is used to bring an item forward or 
backwards on the screen or group and ungroup objects.  The quick styles icon 
gives a drop down with predefined shape style options or you can use the 
shape fill, shape outline, or shape effects icons to create your own styles. 
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Editing 
The Editing section of the toolbar allows you to find, replace 
and select items.  The select option gives you the ability to 
select all, select objects or select text with similar formatting.  
This last option gives you the ability to quickly change 

everything in your document with one style to another style without having to 
manually find all of that text and change each area separately. 

Insert Tab 

 

The insert tab has five  sections for inserting most types of objects.  The 
sections are tables, illustrations, links, text and media clips.   

 

Table 
The table section only has a drop down menu which offers a grid 
to create a new table, insert table, draw table, convert text to table 
for selected text, Excel spreadsheet, and some predefined “Quick 
Tables” that have formatting already setup for you.  When 

working on a table you will have two additional tabs along the top of the 
ribbon, the design and layout tabs.  There are screenshots of both directly 
below. 

Table Design 

 

Table Layout 
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Illustrations 
The Illustrations section allows 
you to insert pictures, clipart, 
photo albums shapes, SmartArt 

and charts.  After inserting or selecting a picture you are provided with a new 

toolbar along the top shown here.   This toolbar gives you the ability to change 
the brightness, contrast, shape, position, text wrapping and other options for 
the picture.  Clicking off the picture or on one of the other tabs will take you 
back to the standard toolbars.  The Shapes option of the Illustrations section 
allows you to insert lines, arrows, boxes, basic flowchart shapes and a number 
of others.  The SmartArt option provides features like org charts, flow charts, 
illustrated lists and processes.  The Chart option is similar to PowerPoint 2003 
but it offers more options for your charts. 

 

Links 
The links section provides options for inserting hyperlinks, or 
actions.  The actions option allows you to link an item to a 
hyperlink, program, sound or macro. 

 

Text 
Options in the text section include text 
box, Header and Footer,  WordArt, 

date and time, slide numbers, symbols and objects.  There are a lot of option 
in here to setup on your own or you can use Words predefined options. 

 

Media Clips 
Sounds or movies can be added through this section.  A large 
number file types can be added here including, mp3, midi, wav 
, wma, wmv, avi and many others. 
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Design Tab 

 

The design tab has three sections, Page Setup, Themes and Background.   

Page Setup 
Page setup provides you with the tools to slide size and 
orientation.  The slide size option allow for some predefined 
sizes like letter, legal, overhead, and tv aspect ratios like 4:3 

standard resolution and 16:9 widescreen.  

Themes 

 

The themes section gives predefined colour, fonts and effects or you can 
choose your own. 

 

Background 
The background section lets you choose a background 
style or hide the background on the selected slide.. 

Animations Tab 

 

The animations tab contains three sections, preview, animations and 
transitions to this slide. 

 

Preview 
The preview section will show you’re the current slides animation to 
allow you to check it is the way you want it. 

 



Computers                                                                                Prak-Sastri 2nd Year 

Directorate of Distance Education, R.S.Vidyapeetha, Tirupati.                        30 
 

Animations 
Here you can create your own animations for use in the 
slide. 

 

Transition to This Slide 

 

The remainder of the Animations tab is taken up by the Transition to This 
Slide section.  Here you can apply different transitions to be used between 
slides like fades, slides and many more.  You can set options for speed, 
sounds, and timing.  

Slide Show Tab 

 

The Slide Show tab contains three sections, start slide show, set up and 
monitors. 

Start Slide Show 
The start slide show section is used to start 
your slide show either from the beginning or 
the current slide.  You can also use this 
section to create a custom slide show.  Custom 

slide shows can be used to create one thirty minute presentation and one sixty 
minute presentation using the same set of slides but omitting some for the 
shorter show. 

 

Set Up 
The main features of this section are setup a 
slide show, record narration and rehearse 
timings. 
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Monitors 
This section provides the tools to change 
the resolution of the slide show choose 
which monitor to display it on if you 

have multiple monitors and use presenter view if you have multiple monitors. 

Review Tab 

 

The review tab offers three sections which include proofing, comments, and 
protect. 

Proofing 
The proofing section provides the standard 
spelling check, a thesaurus, research tools that 
include MSN search and Microsoft Encarta 

encyclopedia.  You will also find translation tools to help with single words or 
the whole document.  The translation of the entire document is done by an 
online service called Wordlingo. 

 

Comments 
The comments section allows you to add 
comments to a document for easier 

collaboration.  You can cycle through the comments to find out what notes 
you left for yourself or others and you can delete a comment that was made 
when it is no longer relevant. 

 

Protect 
The protect section gives you options to add a password and 
protect the document.  You can restrict changes to formatting and 
editing or the whole document.  If you use Windows Live you can 

also manage permissions for specific users who also have Windows Live. 
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View Tab 

 

The view tab offers six sections which include presentation views, show/hide, 
zoom, Color/Greyscale, window and macros. 

 

Presentation Views 
The presentation views section switches you 
between normal, slide sorter, notes page, 
slide show, slide master, handout master and 

notes master.  Normal shows you one slide in the centre with thumbnails of all 
slides to the left of the screen.  Slide sorter fills the centre with thumbnails of 
all slides which you can drag around to sort them.  The notes page view shows 
the slide on the top section and notes you add in a bottom section.  Slide show 
will start the slide show from the beginning.  The Slide master, handout 
master and notes master views allow you to change what the presentations 
themes will follow by working with a master setup.  Each of these master 
views also provide another tab to the ribbon. 

Show/Hide 
The show/hide section will toggle certain tools on or off the 
screen including rulers, gridlinesand message bar.  The rulers 
will show along the top and left side of the screen.  Gridlines 

will cover your entire document inside the margins.  They will be visible on 
screen but don’t print.  The message bar can only be displayed when there is a 
message to be displayed.  One common reason for the message bar to display 
is when macros have been enabled or disabled.   

Zoom 
The zoom section provides tools to zoom into or out of the 
document.   You can choose your own zoom factor or use one 
of the predefined zoom factors. 

Color/Greyscale 
This section allows you to switch between color, 
grayscale or pure black and white.  This will allow you 
to see how slides will look when printed on a black and    

white printer. 
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Window 
The new window button will open your current 
document in a new window.  The arrange all button 
will take your currently open windows and stack 

them one on top of the other.  This is also where you can easily switch 
between windows. 

Macros 
The macros section provides the tools required to work with and 
create basic macros.  You can view existing macros or record your 
own.  Choose record macro from the drop down and then perform the 

functions you do often, like change the page layout, and style of the 
document.  Once you have done those tasks then stop recording.  You will be 
able to use that macro over again to shorten the steps you need to take every 
time you need to perform that set of tasks. 

2.4. Opening a presentation 

The Open window gives you more options for opening an existing 
presentation than the New from Existing window does. You’ll find these 
options useful in certain situations, such as when you want to protect an 
existing presentation by opening it in read-only mode, read through all the 
slides to make sure it’s the one you want, and then save a copy. 

To open an existing presentation using the Open window: 

 Choose Office button → Open (or press Ctrl+O). 

 The Open window appears 

 Select the file you want to open, either by clicking the folder icons you 

see on the left side of the window, or by clicking the “Look in” drop-

down menu. When the PowerPoint file you’re looking for appears in the 

list, click it to select it. 

2.4.1. Creating a presentation 

To create a new presentation with PowerPoint 2007: 

 1. Launch PowerPoint 2007. The program will open up with a new blank 
presentation already created for you. 
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 2. To save the presentation, click on the new Office button and choose Save 
(or click on the Save button in the Quick Access Toolbar). 

 3. Enter a file name for your new presentation and select a save location. 

 4. Click on Save. PowerPoint 2007 uses a different file format than previous 
versions of the program. However, you can save a copy. 

 PowerPoint 2007 presentation that is backward-compatible with older 
versions of the program. To do this, click on the Office button and select Save 
As > PowerPoint 97-2003 Presentation. You should save often as your work 
on your presentation to avoid losing your changes. A quick way to save 
changes as you work is to use the keyboard shortcut Control + S. If you want 
to save a copy of your presentation with a different name, click on the Office 
button, choose Save As > PowerPoint Presentation and enter a different name 
in the File name field at the bottom of the Save As window.  

Another way to create a new presentation: By clicking on the Office button 
and choosing New. This will open the New Presentation window, where you 
will have the following options on the left side: 

• Blank and recent: click on Blank Presentation on the right to create a 
blank presentation with no formatting applied to it.  

• Installed Templates: these are the built-in presentation designs included 
with PowerPoint 2007. 

• Installed Themes: similar to templates, but also include formatting such 
as colors, fonts and effects to give your presentations a consistent look. 

Microsoft Office Online: these are templates you can download from the 
Microsoft website if you have an internet connection. Once you’ve chosen a 
template or theme, click on Create or Download. The formatting options 
included in the template or theme will be applied to the new presentation 
created by PowerPoint 2007. 

2.4.2. Inserting and deleting a presentation 

Working with slides: To add a slide to your presentation, open the Home tab 
in the Ribbon and click on the New Slide button. This will add a new slide 
with the same layout as the previous slide. To change the layout of a slide 
after you’ve added it to your presentation, click on Layout in the Home tab 
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and choose a different layout from the menu. To duplicate an existing slide, 
select the slide in the Slide Pane, right-click on it and choose Duplicate Slide.  

To move a slide so it appears at a different point in the presentation, use drag 
and drop to move the slide’s thumbnail in the Slides Pane (on the left side of 
the window) until it is in the desired location. If you have a long presentation 
with many slides, the Slide Sorter may provide a better view while you 
reorder your slides.  

Another way of adding slide to the presentation 

How to Add Slides to a Presentation  

1. Click the New Slide button on the Formatting toolbar.  

2. From the list of Slide Layouts, select the layout you want to apply to the 
new slide. 

 3. You may now begin adding content using the placeholders in the layout. 

 How to Change the Layout for any Slide 

 PowerPoint will try to guess what layout you want to use for new slides that 
are added to the presentation. If you want a different layout for the slide you 
can quickly change the layout for any slide. 

 1. Display the slide that you want to change in the Slide Pane (work area in 
the center of the window). 

 2. Choose Format > Slide Layout to display the Slide Layout task pane. 

 3. Click on the layout you want to apply to the slide.  

4. PowerPoint will attempt to fit existing content into the new layout, but you 
will probably have to make additional changes. 

How to Add Slides in the Outline Tab 

Create new slides while working in the Outline tab. By default the Outlining 
toolbar should display, but if it does not, select View > Toolbars > Outlining. 
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 1. Display the Outline tab by clicking on Outline in the pane on the left. 

 2. Place the cursor at the end of the text in the slide you wish the new slide to 
follow. 

 3. Click the New Slide button to insert a new slide. 

To delete a slide, press the Delete key on your keyboard with the slide selected 
in the Slide Pane. To hide a slide, right-click on it in the Slide Pane and select 
Hide Slide.  

The hidden slide will be indicated by a square around the slide number in the 
Slides Pane. To unhide the slide, right-click and select Hide Slide one more 
time. 

Adding Content to Slides: The fastest way to add content in PowerPoint is by 
selecting a slide layout and entering your content into one of the text 
placeholders. For example, if you select the Title Slide layout, you can enter a 
title for your slide by clicking on the placeholder text at the top of the Slide 
Canvas and entering your own text.  

You can also add content to a slide by copying it from another document the 
following step should be implemented 

 Select the content you wish to copy in the other document and copy it to the 
clipboard. In most programs this is done by choosing Edit > Copy (if you are 
copying from a Microsoft Office document, click on the Copy button in the  
 Clipboard group of the Home tab). Place your cursor inside the text 
placeholder where you want to paste the copied content.  
 Click on the Paste button in the Clipboard group of the Home tab. Many 
slide layouts also includes bulleted lists. To add text to a bulleted list, click the 
placeholder text next to the first bullet and begin adding the desired text. A 
new item will be added to the list each time you press the Enter key on your 
keyboard. To go to the next line without adding another bullet, hold down the 
Shift key while pressing Enter. 

Many slide layouts also include bulleted lists. To add text to a bulleted list, 
click the placeholder text next to the first bullet and begin adding the desired 
text. A new item will be added to the list each time you press the Enter key on 
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your keyboard. To go to the next line without adding another bullet, hold 
down the Shift key while pressing Enter 

Saving Power Point 

Office button includes a lot of options that used to be found under the file 
menu, such as save and print. Once new presentation with Power Point 2007 
is launched by open up with a new blank presentation/already created by the 
user, the presentation should be saved or save as action should be taken place. 
The following are the steps for saving a presentation 

1. To save the presentation, click on the new Office button and choose Save 
(or click on the Save button in the Quick Access Toolbar). 

2. Enter a file name for your new presentation and select a save location. 

3. Click on Save. 

PowerPoint 2007 uses a different file format than previous versions of the 
program. However, you can save a copy of your PowerPoint 2007 
presentation that is backward-compatible with older versions of the program. 
To do this, click on the Office button and select Save As > PowerPoint 97-
2003 Presentation. You should save often as your work on your presentation 
to avoid losing your changes. A quick way to save changes as you work is to 
use the keyboard shortcut Control + S. If you want to save a copy of your 
presentation with a different name, click on the Office button, choose Save As 
> PowerPoint Presentation and enter a different name in the File name field at 
the bottom of the Save As window. 

 2.4.3. Copying a slide 

A quick way to use slides from one presentation in another presentation is to 

copy the slides that you want to use and paste those slides into the new 

presentation. 

1. Open both presentations to show them at the same time on the screen. 

The original presentation contains the slides you plan to copy, and the 

destination presentation is where they will go. The destination presentation 

may be an existing presentation or a new presentation. 
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2. On the ribbon, go to the View tab. 

3. In the Window group, select Arrange All.  

4. In the Slides pane of the original presentation, right-click 

the thumbnail of the slide to be    copied. 

5. Choose Copy from the shortcut menu. 

6. In the destination presentation, right-click a blank area of 

the Slides pane where you want to place the copied slide. It can be placed 

anywhere in the sequence of slides in the presentation. 

7. Choose a Paste option 

2.5. Slide numbering  

Slide numbers are like page numbers. They show the number of the current 

slide. Slide numbers are easy to add, but they can be frustrating, as well. The 

following steps are considered for adding slide number. 

Step 1: Insert slide number 

The simplest way to insert a slide number in PowerPoint is to navigate to the 

‘Insert’ tab, and then click the icon to ‘Insert Slide Number’. Clicking this 

option opens a pop-up where you check ‘Slide Number’ and then ‘Apply to 

all’ 

Step 2: Add footers in the Slide Master 

If step one didn’t work, let’s level up our slide number skills. Navigate to the 

View tab, and then open the Slide Master. Once you’re in the Slide Master 

you’ll notice that you still have the Insert Slide Number option you did in the 

normal PowerPoint view. For some reason of explicit wizardry, this option 

doesn’t work. 

When you open up the Slide Master it will default onto the page layout for the 

page you we’re viewing in the normal view. If you are struggling to get slide 

numbers on this page it could be because the ‘Footers’ option isn’t checked. 

Checking this should bring up a number of pre-programmed footers on your 

slide. 
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Step 3: Edit the Master Layout 

Step two works if things have been deleted or moved (often by accident) from 

a particular template in your master, but sometimes there are page numbers 

missing across multiple layouts. So to fix this, we go back and open up the 

Slide Master from the View tab and select the main layout. 

Right click and select ‘Master Layout’. 

This will bring up a number of options, one of which… drum roll please… 

will be the option to add a slide number. Make sure this box is checked and it 

should bring up your slide numbers in all their collective glory. 

2.6. Animation and Transition 

Already we have seen that MS PowerPoint, a presentation tool was used to 

create effective and eye-catching presentations in a matter of minutes. It gives 

you a step-by-step creation of a simple presentation, besides introducing you 

to the various features available in PowerPoint. It also details the way in 

which you could make your presentation attractive by changing the font (type, 

size and colour), adding pictures, diagrams and animation. Here now we study 

how animation makes our presentation an eye-catching one. 

 

 Transitions 

To add a transition to a slide: 

 1. Choose the slide in the Slides Pane. 

 2. Open the Animations tab of the Ribbon.  

3. Hover over the transition icons in the Transition to This Slide group to see a 

preview of each transition in the Slide Canvas. When you find one you like, 

click on the icon for that transition. 

4. Use the pulldown menus to the right of the transition icons to add sound 

and change the transition speed. 

 5. Click on “Apply To All” if you wish to apply the currently selected 

transition to all slides in your presentation.  
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To advance the current slide automatically when you present, check the box 

next to “Automatically After” and enter the number of seconds in the field to 

the right. 

 Animation 

To animate any object in the Slide Canvas:  

1. Select the object you wish to animate. 

 2. Select an animation from the Animate pulldown menu in the Animations 

tab of the Ribbon. You will see a preview of the animation in the Slide 

Canvas.  

3. If you wish to create more complex animations, choose Custom Animation 

at the bottom of the Animate pulldown menu. This will open the Custom 

Animation pane on the right side of the window.  

4. Click on Add Effect and choose the type of animation you wish to add 

(Entrance, Emphasis, Exit, or the new Motion Path animation). Clicking on 

each animation type will open a submenu with the animations available under 

that category. 

 5. Once you’ve added an animation, use the pulldown menus under Modify to 

set when the animation will start (On Click, With Previous or After Previous) 

and the animation speed. Depending on the animation type you select, you 

may see additional pulldown menus for changing the animation direction or 

path. 

 6. Use the arrows under the animations list to change the order in which the 

animations will be executed when you play the slide. To remove an animation, 

select it from the list and click on the Remove button at the top of the pane.  

7. Click on Play to preview your animation in the Slide Canvas. 
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Motion paths: 

Motion paths allows you to select a path that will apply to the selected object 

or text. Various options are available and are detailed further in this unit. 

Motion paths is the ability to animate an object so it moves along a path. To 

add a motion path animation:  

1. Select the object you wish to animate. 

 2. Choose Custom Animation from the Animate pulldown menu of the 
Animations tab. The Custom Animation task pane will open on the right side 
of the window.  

3. Click on Add Effect and choose Motion Paths. 

 4. Select a path from the list or select Draw Motion path to draw the path 
yourself. 

 5. Each path will have a start point and an end point. 

Selecting the desired effect: By applying one or more of these to see the 
effect on the object, item, or text and choose the one that appeals the most. 

Effects available under each of the categories are shown below. 
Entrance 

(1) Blinds 
(2) Box 
(3) Checkerboard 
(4) Diamond  
(5) Fly In 

Emphasis  
(1) Change Font 
(2) Change Font Size 
(3) Change Font Style 
(4) Grow/Shrink 
(5) Spin 

Exit 
(1) Blinds 

(2) Box 
(3) Checkered box 
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(4) Diamond 

(5) Fly In 

Motion Paths  
(1) Diagonal Down Right 

(2) Diagonal Up Right 

(3) Down 

(4) Left 
(5) Right 

(6) Up 

 

2.7. Summary 
 In this unit, you have studied that a PowerPoint presentation consists 

of individual slides arranged in a sequential manner. New slides can be 

inserted, existing slides can be deleted and slides can be re-ordered 

within a presentation. Presentations can then be saved in the default 

directory (which can be changed, if required) with a .ppt extension. 

 You can also customize your presentation and control the appearance 

by adding pictures, objects and animation to it thereby giving it an 

attractive look. 

 

 

2.8 SAQ 

 

1. Write short notes on commonly used slides in Power Point? 

2. Write short notes on how to implement animation in Power Point? 

3. How to insert graphs in Power Point? 

4. Discuss the steps involved in inserting sound and video in Power  

             Point? 

5.         Discuss how to create presentation? 

 
 

 
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Unit – III Introduction to MS Excel 

 

Structure 

3.0. Objective 
3.1. Basics 

3.1.1. Creating, inserting and deleting a worksheet 
3.1.2. Menus 

3.2. Formatting 
3.3. Renaming and Labeling a worksheet 
3.4. Finding and Replacing the data 
3.5. Summary 
3.6. S.A.Q 

3.0. Objective 

Students should be able to 

 Identify the MS Excel screen layout and its components, and 

 Identify various menus and their functions. 
 know the MS Excel Standard Toolbar and the Formatting Toolbar and 

its components, and 

 Learn various functions and formulas of MS Excel. 

3.1. Basics 

               MS Excel is a powerful spreadsheet program through which you 

can create tables of any kind. These tables may contain numeric values, text 

data or formulas. You can use Excel to automate simple tasks like giving 

lists or to create sophisticated analysis tables for calculating the future trends 

in the stock market. 

 Excel features 

Conditional Formatting: You can format cells/data according to condition 
and can get glimpse of entire data within seconds. 

VBA, Macros & automation: This would make computer work for you. You 
can automate mundane job for you.  
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Pivot Tables: Worried about how you’ll interpret data. Let excel do it for 
you. This is to must know feature of excel. 

Lookup Formulas: This formula is deadly. Combination of it with match, 
index can help in doing wonders. 

Power Pivot: It helps in querying the huge data effectively. Has been 
introduced in recent version. 

Add Header and Footer 

MS Excel allows us to keep header and footer in out spreadsheet document. 

Find and Replace Command 

MS Excel allows us to find the needed data (text and number) in the 
workbook and also replace the existing data with a new one. 

Password protection 

It allows user to protect their workbooks by using password from 
unauthorized access to their information. 

Data filtering 

Filtering is a quick and easy way to find and work with a subset of data in a 
range. A filtered range displays only the rows that meet the criteria you 
specify for a column. MS Excel provides two commands for filtering ranges: 

 Auto filter: which includes filter by selection, for simple criteria 

 Advanced filter: for more complex criteria 

Data sorting 

Data sorting is the process of arranging data in some logical order. MS Excel 
allows us to sort data either in ascending or descending order. 

Built in formulae 

MS Excel has got many built – in formulae for sum, average, minimum, etc. 
We can use those formulae as per our needs. 

Automatically edits the result 

MS Excel automatically edits the result if any changes are made in any of the 
cell. 
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3.1.1. Creating, inserting and deleting a worksheet 
 

A Work sheet, in the word's original meaning, is a sheet of paper on which 
one performs work. Microsoft Excel, a popular spreadsheet program, refers to 
a single spreadsheet as a worksheet, and it refers to a collection 
of worksheets as a workbook. 

a) Creating new worksheet: To create new worksheet following steps should 

be implemented 

 Click the file tab. 

 Click new 

 Under templates, click New from existing. 

 In the New from Existing Workbook dialog box. 

 Click the workbook, and then click Create New. 

b) Inserting and deleting worksheet 

 Inserting and deleting worksheets in Excel is a critical skill to possess when 
working within a workbook in Excel. 

            To insert a single new worksheet at the end of the current listing of 
worksheets, click the “New Sheet” button at the right end of the spreadsheet 
name tabs. Alternatively, you can also click the “Home” tab in the Ribbon. 
Then click the “Insert” drop-down button within the “Cells” button group. 
Then select the “Insert Sheet” command from the drop-down menu. 
Alternatively, you could press the keyboard shortcut of “Shift”+“F11” on your 
keyboard to automatically insert a new worksheet. If using these last two 
methods, however, note that the new worksheets will always be inserted to the 
left of the worksheet name that appears in bold when the sheet is inserted. 

            Deleting old worksheets that you no longer use can reduce worksheet 
clutter in workbooks. You can easily delete worksheets in Excel. Simply 
select the worksheet name tabs of the sheet or the sheets that you want to 
delete. Then click the “Delete” button in the “Cells” group on the “Home” tab 
in the Ribbon. Then click the “Delete Sheet” choice in the button’s drop-down 
menu to delete the selected worksheets. 

The following are the instructions for inserting and deleting worksheets in 

Excel 
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 To insert a single new worksheet at the end of the current listing of 

worksheets, click the “New Sheet” button at the right end of the 

spreadsheet name tabs. 

 Alternatively, click the “Home” tab in the Ribbon. 

 Then click the “Insert” drop-down button within the “Cells” button 

group. 

 Then select the “Insert Sheet” command from the drop-down menu. 

 Alternatively, you could also press the keyboard shortcut of 

“Shift”+“F11” on your keyboard to automatically insert a new 

worksheet. 

 If using these last two methods, however, note that the new worksheets 

will always be inserted to the left of the worksheet name that appears 

in bold when the new sheet is inserted. 

 To delete worksheets in Excel, select the worksheet name tabs of the 

sheet or the sheets you want to delete. 

 Click the “Delete” button in the “Cells” group on the “Home” tab in 

the Ribbon and choose the “Delete Sheet” choice from the button’s 

drop-down menu. 

c) saving worksheet in Excel 

Save As 

To save your work often or you risk losing your Excel data if the computer 
crashes or the power goes out. When you save a workbook for the first time, 
you see the Save As dialog box. The appearance and functionality of the Save 
As dialog box varies depending on whether you are running Excel 2007, 2010 
and so on. Follow these steps to save your workbook when running Excel 
2007.  

1. Click the Office button and choose Save. The Save As dialog box 

appears. 

2. Click the Browse Folders button (with the triangle pointing 

downward) to expand the Save As dialog box if necessary. 
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3. When you expand the Save As dialog box, the dialog box displays the 

Navigation Pane, where you can select folders listed in the Favorite 

Links or Folders sections. 

4. In the Navigation Pane, select the folder in which you want to save the 

file. Type a descriptive name for the file in the File Name box. 

5. Click the Save button to save the file in the selected folder. 

Save :Follow these steps to save your workbook when running Excel 

2007 on Windows XP: 

6. Click the Save In drop-down list button and select the folder in which 

you want to save the file. 

7. Type a descriptive name for the file in the File name box. 

8. Click the Save button to save the file in the selected folder. 

 
3.1.2. Menus 

The office button is at the top left-hand corner of the Ribbon. 
It replaces the File Menu of earlier  versions of  Office and Excel.  
It is used to Open, Save, Print and Close files.  

 

THE RIBBON 

The commands are organized by Tab and Group. 
At the highest level is the Ribbon for each Tab.  
Here this is is shown for the Home Tab.   
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Eventually we want to get to commands that we use.  From the Ribbon the 

sequence is  

1. Tabs: 

- The seven tabs are Home, Insert, Page Layout, Formulas, Data, 

Review, View. 

- The above example uses the Home tab. 

2. Groups: 

- These show related items together. 

- For example, there is the Font group (within the Home tab).  

3. Commands  

- A command is a button, a box to enter information, or a menu. 

- For example, there is the B button (in the Font group in the  Home 

tab) to make text bold.  

- The Dialog Box launcher is a small arrow that gives additional 

commands (e.g. at bottom right of the Font group). 

 
THE RIBBON FOR EACH OF THE SEVEN TABS 
 
1. Home Tab - Use to read in data and save data in various formats. 
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2. Insert  Tab - Use to create Charts. 
 

 
 
3. Page Layout Tab 
 

 
 
 
4. Formulas Tab 
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5. Data Tab - Use the Data Analysis add-in for histograms, descriptive 
statstics, regression, .... 
 

 
 
6. Review Tab 
 

 
 
7. View Tab 
 

 

3.2. Formatting 

Excel makes available numerous formatting options to give your 
worksheet a polished look. You can change the size, colour and angle of fonts, 
add colour to the borders and backgrounds of cells, and have the format of a 
cell change, based on its value. You will see that some of the formatting 
features in MS Excel are same as you have used in MS Word. 

USING FORMATTING TOOLBAR 

 Formatting helps to make our work more presentable. It also helps the 

viewer/reader to understand the worksheet more easily with respect to its 
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purpose. There are three locations where the Excel 2007 formatting tools are 

available. 

 

1. In the home tab  

2. In the mini toolbar that appears when you right click a range or a 

cell  

3. In the format cells dialog box. 

 

Home Tab and the Formatting Tools: Home tab provides the quick access 

to the most commonly used options with respect to the formatting 

requirements. You can select a cell or a range and then use the tool as per the 

need like Font, Alignment or Number groups. To understand the proper and 

best use of such tools, only way is to use them and experience their effect. 

Some of the controls are further expandable like drop-down lists etc. If you 

see some small arrow along with a button. The button will expand to display 

the available choices. 

 

In the Mini Toolbar: shortcut menu appears when you right click a cell or a 

range selection. A mini toolbar also appears above the shortcut menu. The 

Mini toolbar contains controls for common formatting: 

 Font type  

 Font Size 

 Decrease Font  

 Increase Font 

  Accounting Number Format  

  Comma Style 

  Font Color  

  Format Painter  

  Bold  

  Italic 

  Center  
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  Percent Style 

  Borders  

  Merge And Center  

  Increase Decimal  

  Decrease Decimal 

 Fill Color 

Using the Format Cells dialog box: 

 Although most of the formatting related requirements gets fulfilled by the 

controls available on the Home tab of the Ribbon, some special types of 

formatting are fulfilled by using Format cells dialog box.  

This dialog box allows to apply more or less any type of formatting style and 

number formatting. The formats selected from Format Cells Dialog box will 

be effective to the cells which are selected at the time. 

 To use Format Cells dialog box, select the cell or a range to apply formatting. 

Now choose any of the following methods 

 Press the combination of Ctrl+1, i.e., Control key and numeric 1 key. 

 Click the dialog box launcher in Home → Font, Home → Alignment, 

or Home → Number. A small down word pointing arrow icon will be 

displayed to the right. In the Excel Ribbon, these arrow marks are 

known as dialog box launcher. 

Choose Format Cells from the shortcut menu after you Right-click the 

selected cell or range. 

  Click the More command in some of the drop-down controls in the 

Ribbon. For example, the Home → Number→ General → More 

Number Formats… drop-down includes an item named More Number 

Formats. 

 

5.5.1 Cell FORMATTING  

There are six tabs in Format Cells dialog box: Number, Alignment, Font, 

Border, Patterns and Protection. 
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Number tab: The data type can be selected from the options on this tab. 

Select the range you would like to format and click on one of the category 

number. And apply that style to your numbers.  

Alignment tab: These options allow you to change the position and alignment 

of the data with the cell. The Format Cells dialog box offers you more options 

than the alignment buttons on the Formatting toolbar. For example, you can 

change the orientation of the text.  

Font tab: All of the font attributes are displayed in this tab including font 

face, size, style, and effects. Using Formatting toolbar you can bold, italicize, 

and underline your cell entries. For even more formatting options you can use 

the Format Cells dialog box. 

Border and Pattern tabs:  

You can use the Formatting toolbar for adding borders, cell shading, and font 

colour. These buttons are actually tear-off palettes. When you click on the 

picture portion of the button, the format of the picture displayed will be 

applied to the contents of the cell(s) you have selected in the worksheet. You 

can change the picture displayed on the button by clicking on the button’s 

small drop-down arrow to access the palette of samples from which to choose. 

Follow these steps to apply a border and colour to a selection using the 

options in the Format Cells dialog box.  

1. Select Format→Cells to display the Format Cells dialog box. 

2. Select the Border tab.  

3. In the Presets area, choose None, Outline, or Inside to specify the 

location for the border.   

4. Choose any of the following options for the border: 
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 In the Border area, click on any of the buttons to toggle its 

border. 

 Choose the border’s line style in the Style area. 

 If necessary, select a colour for the border in the Color 

Palette. 

5. Select the Patterns tab, and then choose any of the following 

options: 

 Select a colour for the background of the selection in the 

Color palette.  

 If necessary, select a pattern for the background of the 

selection in the Pattern palette. 

6. Choose OK to apply the border and colour. 

Dates and Times 

If you enter the date “January 1, 2001” into a cell on the worksheet, Excel will 

automatically recognize the text as a date and change the format to “1-Jan-

01”. To change the date format, select the Number tab from the Format Cells 

window. Select “Date” from the Category box and choose the format for the 

date from the Type box. If the field is a time, select “Time” from the Category 

box and select the type in the right box. Date and time combinations are also 

listed. Press OK when finished. 

Formatting Columns and Rows: 

Sometimes the contents of the columns do not fit in its width. So, to adjust 

them within the width of the column, we can use AutoFit feature. 

Steps to AutoFit Columns: 



Computers                                                                                Prak-Sastri 2nd Year 

Directorate of Distance Education, R.S.Vidyapeetha, Tirupati.                        55 
 

 Click on Column Header/or any other cell in the column to change its 

width. 

 Click Home tab. 

 Select format from the cells group on the ribbon. 

 Click on AutoFit Column Width. 

Similarly you can apply AutoFit for row also.  

 Click on Row Header/or any other cell in the Row to change its 

Height. 

 Click Home tab. 

 Select format from the cells group on the ribbon. 

Another way of automatically adjusting columns and rows is by way of best 

fit. Follow the below steps:  

 Place your pointer on or near the right edge of a column header of the 

column you wish to adjust. Notice that in this area your pointer 

changes to a double-headed arrow. 

 Double click your pointer, and the column to the left of it will 

automatically adjust to fit the data entries within it. Similarly, pointing 

to a row header changes pointer to a double headed arrow. Double 

clicking results in a best fit (taller or shorter rows). 

Hide Selected Column(s) or Row(s) 

 Hide - Hides the selected column(s) or row(s), though the data is still there. 

Hiding column(s) or row(s) will help you to prevent unwanted changes. To 

hide a column, follow these steps: 

 Select the column you want to hide by clicking on the column header. 

 Right Click on the Column to hide and click on the Hide option. 
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Unhide Selected Column(s) or Row(s) 

To unhide the column follow these steps:  

 Select the visible range of columns that includes the hidden column(s). 

 Now Right Click on the selected Columns. Select Unhide from the 

pop-up menu. 

FORMATTING WORKSHEETS USING CELL STYLES AND 

APPLYING STYLES: 

Excel 2007 provides cell styles to quickly format a cell by choosing from 

predefined styles. Styles help to give a professional look to your worksheets. 

In Excel, all styles are cell styles. However, a defined style can be applied to 

an entire worksheet. Cell styles can include any of the formatting that can be 

applied to a cell using the options available. We can also define our own cell 

styles. 

 Select the cells to apply a style on. 

 Choose Home tab. From Styles group, Click on Cell Styles. 

A few of the effects are discussed below 

 Comma - Adds commas to the number and two digits beyond a 

decimal point. 

 Comma [0] - Comma style that rounds to a whole number. 

 Currency - Formats the number as currency with a dollar sign, 

commas, and two digits beyond the decimal point. 

 Currency [0] - Currency style that rounds to a whole number. 

  Normal - Reverts any changes to general number format. 

 Percent - Changes the number to a percent and adds a percent sign. 

Deleting Styles: 
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 Right click on the style (say if you want to remove Bad Style)  

 Choose delete. 

3.3. Renaming and labeling a worksheet 

Naming worksheets 

When you open an Excel workbook, there are three sheets by default, and 
the default name on the tabs are Sheet1, Sheet2, and Sheet3. These are not 
very informative names. Excel 2007 allows you to create a meaningful name 
for each worksheet in a workbook so you can quickly locate information. 

To name a worksheet: 

 Right-click the sheet tab to select it. 

 Choose Rename from the menu that appears. The text is 
highlighted by a black box. 

 
 Type a new name for the worksheet. 

 
 Click off of the tab. The worksheet now assumes the 

descriptive name defined. 
OR 

 Click the Format command in the Cells group on the Home 
tab. 
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 Select Rename Sheet. The text is highlighted by a black box. 

 Type a new name for the worksheet. 

 Click off of the tab. The worksheet now assumes the 
descriptive name defined. 

Inserting worksheets 

You can change the default number of sheets that appears by clicking 
the Microsoft Office button and choosing Excel Options. You also have the 
ability to insert new worksheets if needed while you are working. 

To insert a new worksheet: 

 Left-click the Insert Worksheet icon. A new sheet will appear. 
It will be named Sheet4, Sheet5, or whatever the next 
sequential sheet number may be in the workbook. 

 
OR 

 Press the Shift and the F11 keys on your keyboard. 

Deleting worksheets 

Any worksheet can be deleted from a workbook, including those that have 
data in it. Remember, a workbook must contain at least one worksheet. 

To delete one or more worksheets: 

 Click on the sheet(s) you want to delete. 

 Right-click the sheet(s), and a menu appears. 

 Select Delete. 
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OR 

 Select the sheet you want to remove. 

 Click the drop-down arrow next to Delete in the Cells group 
on the Home tab. 

 From the menu that appears, select Delete Sheet 

3.4. Finding and Replacing the data 

Excel 2007’s Find and Replace feature can be a powerful tool. Use Find and 

Replace to locate and optionally replace text or values in a worksheet. You 

can narrow the search results by specifying formatting to look for as well as 

other search options, including Match Case. 

Finding data 

Follow these steps to locate data in a worksheet: 

1. Choose Find & Select in the Editing group on the Home tab, and then select 
Find (or press Ctrl+F). 

The Find and Replace dialog box appears, with the Find tab on top. 

2. In the Find What box, enter the data you want to locate. 

3. (Optional) Click the Options button to expand the dialog box and specify any 
desired options. 

o Within: Search just the current worksheet or the entire workbook. 
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o Search: Select whether to search first across the rows or down the 
columns. 

o Look In: Select whether you want to search through the values or 
formula results, through the actual formulas, or if you want to look in 
the comments. 

o Match Case: Check this box if you want your search to be case-
specific. 

o Match Entire Cell Contents: Check this box if you want your search 
results to list only the items that exactly match your search criteria. 

 

Specify search options on the Find tab in the Find and Replace dialog 

box. 

4. Click Find Next. 

Excel jumps to the first occurrence of the match. If this isn’t the entry you’re 
looking for, click Find Next again. Excel advises you if it doesn’t find the data 
you’re searching for. 

5. Click Close when you’ve located the entry you want. 

Note: use wildcards to search for data in your worksheets. Use the ? (question 
mark) to indicate a single unknown character, or the *(asterisk) to indicate 
multiple unknown characters. 
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Replacing data 

To find and replace data in a worksheet, follow these steps: 

1. Choose Find & Select in the Editing group on the Home tab, and then select 
Replace (or press Ctrl+H). 

The Find and Replace dialog box appears with the Replace tab on top. 

2. In the Find What box, enter the data you want to locate. 

3. In the Replace With box, enter the data with which you want to replace the 
found data. 

 

Use the Find and Replace feature to exchange data in Excel 2007. 

4. (Optional) Click the Options button and specify any desired options. 

5. Click Find Next to locate the first occurrence or click Find All to display a list 
of all occurrences. 

You can sort the results of a Find All search by clicking a column heading. 

6. If you want to use the replacement data, click Replace. 

Excel performs the replacement and locates the next occurrence. 

7. If you want to replace all occurrences at the same time, click Replace All. 

Excel displays an information box indicating the number of replacements 
made. 

8. Click OK in the alert box and then click Close. 
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3.5. Summary 

 MS Excel is a powerful spreadsheet program through which you can 
create tables of any kind. 

 Excel features: You can format cells/data according to condition and 
can get glimpse of entire data within seconds. Pivot tables, lookup 
formulas, power pivot, add header and footer, find and replace, pass 
word protection, data filtering, built in formulae and many more. 

 Formatting Columns and Rows: 
 Sometimes the contents of the columns do not fit in its width. So, to 

adjust them within the width of the column, we can use AutoFit 
feature. 

3.6. SAQ 

1. What is Excel? List features of Excel? 
2. Explain how to create, insert and save a worksheet? 
3. What is formatting a cell? Explain? 

 

 

  
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Unit IV MS Excel 

 
 

Structure 

0.4. Objective 

4.1. Sorting 

4.2. Functions 

4.3. Creating and Editing charts and Graphs 

4.4. Printing Worksheets 

4.5. Steps involved in problem solving 

4.6. Algorithm 

4.7. Flowchart 

4.8. Summary 

4.9. SAQ 

4.0. Objective 

Already we have studied the basic concepts of MS Excel such as formatting 

toolbar, its components, menus etc. Let us learn about sorting the data in 

ascending or descending order, functions and formulas of MS Excel, how to 

print worksheets, flowcharts and graphs. Finally we learn about algorithms 

which help in designing the problem solving operations in programming.  

4.1.  Sorting 
 

Data sorting is the process of arranging data in some logical order. MS Excel 

allows us to sort data either in ascending or descending order. If your Excel 

2007 worksheet has become quite large, using the Sort dialog box to sort on 

multiple columns can make it easier to find the data you need. The Sort dialog 

box lets you tell Excel what column to sort on next if two cells in the main 

sort column contain the same value or data. The following are the steps 

involved in sort the data.  
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1. Select or click in the list of data you want to sort. 

You can select only a single column of data if you want to sort that column 

independently of the rest of the data. However, in most cases, you likely want 

to sort the entire list. 

 
2. Click the Sort button in the Sort & Filter group on the Data tab. 

The Sort dialog box appears. If your data includes column headings, make 

sure the My Data Has Headers option is checked. Excel can usually detect the 

correct setting automatically. 

 
3. From the Sort By drop-down list, select the column by which you 

want to sort. 

This drop-down list includes the column headings for each column in the list. 

4. From the Sort On drop-down list, choose Values. 

Notice that you also can perform the sort on Cell Color, Font Color, or Cell 

Icon. Typically, you will perform a sort based on values rather than 

formatting. 

5. From the Order drop-down list, select how you want to sort the 

data. 

The options that appear in this list change based on the contents of the sort 

column. Choose A to Z or Z to A to sort text values, Smallest to 

Largest or Largest to Smallest to sort numeric data, or Oldest to 

Newest or Newest to Oldest to sort by dates. 

6. Click the Add Level button. 

Additional drop-down list boxes appear for the secondary sort column. 
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7. From the Then By list, select the secondary column you want to 

sort on. 

This is the column Excel will sort by if two or more items are identical in the 

first Sort By option. 

8. Select how you want to sort the second data criteria. 

After you specify the options for the secondary sort column, you can add more 

sort columns as needed. Use the Move Up and Move Down buttons if you 

decide to change the order of the sort columns. 

 
9. Click OK. 

The dialog box closes and Excel performs the sort process. 

4.2. Functions 

A function is a predefined formula that performs calculations using specific 

values in a particular order. Excel includes many common functions that can 

be used to quickly find the sum, average, count, maximum value, 

and minimum value for a range of cells. In order to use functions correctly, 

you'll need to understand the different parts of a function and how to 

create arguments to calculate values and cell references.  

5.7.1 Function: In order to work correctly, a function must be written a 

specific way, which is called the syntax. The basic syntax for a function is 

the equals sign (=), the function name (SUM, for example), and one or 
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more arguments. Arguments contain the information you want to calculate. 

The function in the example below would add the values of the cell range 

A1:A20. 

 

Working with arguments: Arguments can refer to both individual 

cells and cell ranges and must be enclosed within parentheses. You can 

include one argument or multiple arguments, depending on the syntax 

required for the function. 

For example, the function =AVERAGE(B1:B9) would calculate 

the average of the values in the cell range B1:B9. This function contains only 

one argument. 

 

Multiple arguments must be separated by a comma. For example, the 

function =SUM(A1:A3, C1:C2, E1) will add the values of all of the cells in 

the three arguments. 
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Creating a function: There are a variety of functions available in Excel. Here 

are some of the most common functions. 

 SUM: This function adds all of the values of the cells in the 

argument. 

 AVERAGE: This function determines the average of the 

values included in the argument. It calculates the sum of the 

cells and then divides that value by the number of cells in the 

argument. 

 COUNT: This function counts the number of cells with 

numerical data in the argument. This function is useful for 

quickly counting items in a cell range. 

 MAX: This function determines the highest cell 

value included in the argument. 

 MIN: This function determines the lowest cell value included 

in the argument. 

To create a function using the AutoSum command: 

The AutoSum command allows you to automatically insert the most common 

functions into your formula, including SUM, AVERAGE, COUNT, MIN, and 

MAX. In the example below, we'll use the SUM function to calculate the total 

cost for a list of recently ordered items. 

1. Select the cell that will contain the function. In our example, 

we'll select cell D13. 
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2. In the Editing group on the Home tab, click the arrow next to 

the AutoSum command. Next, choose the desired 

function from the drop-down menu. In our example, we'll 

select Sum. 

 
3. Excel will place the function in the cell and automatically 

select a cell range for the argument. In our example, 

cells D3:D12 were selected automatically; their values will 

be added to calculate the total cost. If Excel selects the wrong 

cell range, you can manually enter the desired cells into the 

argument. 

 
4. Press Enter on your keyboard. The function will 

be calculated, and the result will appear in the cell. In our 

example, the sum of D3:D12 is $765.29. 
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The AutoSum command can also be accessed from the Formulas tab on 

the Ribbon. 

 

You can also use the Alt+= keyboard shortcut instead of the AutoSum 

command. To use this shortcut, hold down the Alt key and then press 

the equals sign. 

To enter a function manually: 

If you already know the function name, you can easily type it yourself. In the 

example below (a tally of cookie sales), we'll use the AVERAGE function to 

calculate the average number of units sold by each troop. 

1. Select the cell that will contain the function. In our example, 

we'll select cell C10. 
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2.  

 
3. Type the equals sign (=), and enter the desired function 

name. You can also select the desired function from the list 

of suggested functions that appears below the cell as you type. 

In our example, we'll type =AVERAGE. 

 
4. Enter the cell range for the argument inside parentheses. In 

our example, we'll type (C3:C9). This formula will add the 

values of cells C3:C9, then divide that value by the total 

number of values in the range. 
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5. Press Enter on your keyboard. The function will be calculated, 

and the result will appear in the cell. In our example, the 

average number of units sold by each troop is 849. 

 

The Function Library 

While there are hundreds of functions in Excel, the ones you'll use the most 

will depend on the type of data your workbooks contain. There's no need to 

learn every single function, but exploring some of the different types of 

functions will help you as you create new projects. You can even use 

the Function Library on the Formulas tab to browse functions by category, 

such as Financial, Logical, Text, and Date & Time. To access the Function 

Library, select the Formulas tab on the Ribbon.  
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To insert a function from the Function Library: 

In the example below, we'll use the COUNTA function to count the total 

number of items in the Items column. Unlike COUNT, COUNTA can be 

used to tally cells that contain data of any kind, not just numerical data. 

1. Select the cell that will contain the function. In our example, 

we'll select cell B17. 

 
2. Click the Formulas tab on the Ribbon to access the Function 

Library. 

3. From the Function Library group, select the desired function 

category. In our example, we'll choose More Functions, then 

however the mouse over Statistical. 
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4. Select the desired function from the drop-down menu. In our 

example, we'll select the COUNTA function, which will count 

the number of cells in the Items column that are not empty. 

 
5. The Function Arguments dialog box will appear. Select 

the Value1 field, then enter or select the desired cells. In our 

example, we'll enter the cell range A3:A12. You may continue 
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to add arguments in the Value2 field, but in this case we only 

want to count the number of cells in the cell range A3:A12. 

6. When you're satisfied, click OK. 

 
7. The function will be calculated, and the result will appear in 

the cell. In our example, the result shows that a total of 10 

items were ordered. 
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4.3. Creating, editing Charts  and graphs 

In Microsoft Excel, a chart is often called a graph. It is a visual representation 

of data from a worksheet that can bring more understanding to the data than 

just looking at the numbers. 

A chart is a powerful tool that allows you to visually display data in a variety 

of different chart formats such as Bar, Column, Pie, Line, Area, Doughnut, 

Scatter, Surface, or Radar charts. With Excel, it is easy to create a chart. 

The following are some of the types of charts that you can create in Excel. 

Bar Chart 

 
Column Chart 

 

Pie Chart 
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Line Chart 

 

To create a chart follow the steps given below: 

 Select the worksheet you want to work with. In this example, 

we use the Summary worksheet. 

 Select the cells you want to chart, including the column 

titles and row labels. 

 Click the Insert tab. 

 Hover over each Chart option in the Charts group to learn 

more about it. 

 Select one of the Chart options. In this example, we'll use the 

Columns command. 

 Select a type of chart from the list that appears. For this 

example, we'll use a 2-D Clustered Column. The chart appears 

in the worksheet. 
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Identifying the parts of a chart 

Charts are a visual representation of data in a worksheet. Charts make it easy 

to see comparisons, patterns, and trends in the data. 

 

Source data 

The range of cells that make up a chart. The chart is updated automatically 

whenever the information in these cells changes.  

 Title:The title of the chart. 
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 Legend: The chart key, which identifies what each colour on the chart 

represents. 

 Axis:  The vertical and horizontal parts of a chart. The vertical axis is 

often referred to as the Y axis, and the horizontal axis is referred to as 

the X axis. 

 Data series: The actual charted values, which are usually rows or 

columns of the source data. 

 Value axis: The axis that represents the values or units of the source 

data. 

 Category axis: The axis identifying each data series. 

 Chart tools: Once you insert a chart, a new set of Chart Tools, 

arranged into three tabs, will appear above the Ribbon. These are only 

visible when the chart is selected. 

 

To change the chart type: 

 Select the Design tab. 

 Click the Change Chart Type command. A dialog box 

appears. 

 
 Select another chart type. 
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 Click OK. 

The chart in the example compares each salesperson's monthly sales to his or 

her other months' sales; however, you can change what is being compared. 

Just click the Switch Row/Column Data command, which will rotate the data 

displayed on the x and y axes. To return to the original view, click the Switch 

Row/Column command again. 

To change chart layout: 

 Select the Design tab. 

 Locate the Chart Layouts group. 

 Click the More arrow to view all of your layout options. 

 
 Left-click a layout to select it. 

If your new layout includes chart titles, axes, or legend labels, just insert your 

cursor into the text and begin typing to add your own text. 

To change chart style: 

 Select the Design tab. 

 Locate the Chart Style group. 

 Click the More arrow to view all of your style options. 

 Left-click a style to select it. 
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To move the chart to a different worksheet: 

 Select the Design tab. 

 Click the Move Chart command. A dialog box appears. The 

current location of the chart is selected. 

 Select the desired location for the chart (i.e., choose an existing 

worksheet, or select New Sheet and name it). 

 

 

4.4.Printing worksheets 

Before printing a spreadsheet or pivot table, it is used to previewing and 
adjusting it for better readability.  This can be done in different methods. The 
following are the two methods to page set up and print worksheet in MS Excel 
2007. 

Page Setup  
To modify the page setup 

(1) Choose Page Setup from the File menu. Page Setup allows you to 
set page options like Margins, Paper Settings, Page Layout and 
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Document Grid. Options for the same are provided through four 
tabbed sub-menus. 

1. Page :You can set your page settings here. 
2. Margins: You can set the margins here. 
3. Header/Footer :You can define the header and footer of the page 

here. 
4. Sheet :You can define your sheet formatting here. 

(A) Page Settings 
(a) Click here to define the paper orientation; 
(b) Click here to define the printer settings; 
(c) Click here to see the print preview; 
(d) Click here to define the print options; 
(e) Click here to define the page scaling; 
(f) Click here to define the paper size here; 

4. Click here to define the print quality; and 
 Click here to define the first page number. 

(B) Margin Settings 

 Click here to define the Top margin setting; 

 Click here to define the Header margin setting; 

(c) Click here to define the Left margin setting; 

(d) Click here to define the Right margin setting; 

(e) Click here to define the Bottom margin setting;  

(f) Click here to define the Footer margin setting; and 

(g) Click here to define the Center alignment of the page. 

(C) Header/Footer 
(a) Click here to customize your header; and 
(b) Click here to customize your footer. 
 

(D) Sheet 
(a) Click here to define the print area; 
(b) Click here to define thecolumn and rows title; 
(c) Click here to print the gridlines, draft quality, row and 

column heading, cell errors or to print the worksheet in 
black and white; and 
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(d) Click here to define the page order in. 

Print  
To print the document or the template. 

1. Choose Print from the File menu to print your worksheet or a 
selection of your worksheet. 

2. Select the Printer name here. 
1. Click here to change the printing options for the selected 

printer. 
2. Click here to find the network printer based on the printer 

name, model etc. 
3. Click here to print your document in a file instead of a 

printer. 
3. Click here to select the page or the page range you want to print. 

 (D) Click here to define the number of copies you want to print. 
4. Choose the worksheet or the entire workbook that you want to 

print. 
(E) Click here to see preview of the workbook or the worksheet 

you have selected to print. 

5. Click on OK Once you have defined your print settings. 

Print Preview 

Displays the full page as it will be displayed on the paper. 

(1) Choose Print Preview from the File menu to see, how your 
worksheet or a selection of your worksheet will look like on paper. 

(A) This will, howyourworksheet or a selection of your 
worksheet, will look like on paper. 

4.5. Steps involved in problem solving 

A computer is a very powerful and versatile machine capable of 

performing a multitude of different tasks, yet it has no intelligence or 

thinking power. The intelligence Quotient (I.Q) of a computer is zero. A 

computer performs many tasks exactly in the same manner as it is told to 

do. This places responsibility on the user to instruct the computer in a 

correct and precise manner, so that the machine is able to perform the 

required job in a proper way. A wrong or ambiguous instruction may 

sometimes prove disastrous. In order to instruct a computer correctly, the 
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user must have clear understanding of the problem to be solved. A part 

from this he should be able to develop a method, in the form of series of 

sequential steps, to solve it. Once the problem is well-defined and a 

method of solving it is developed, then instructing the computer to solve 

the problem becomes relatively easier task. Thus, before attempt to write a 

computer program to solve a given problem. It is necessary to formulate or 

define the problem in a precise manner. Once the problem is defined, the 

steps required to solve it, must be stated clearly in the required order. 

A computer cannot solve a problem on its own. One has to provide step by 

step solutions of the problem to the computer. In fact, the task of problem 

solving is not that of the computer. It is the programmer who has to write 

down the solution to the problem in terms of simple operations which the 

computer can understand and execute. 

The following are the steps involved in problem solving 

1. Understanding the problem  

2. Analyzing the problem 

 3. Developing the solution 

 4. Coding and implementation.  

1. Understanding the problem: Here we try to understand the problem to be 

solved in totally. Before with the next stage or step, we should be absolutely 

sure about the objectives of the given problem. 

2. Analyzing the problem: After understanding thoroughly the problem to be 

solved, we look different ways of solving the problem and evaluate each of 

these methods. The idea here is to search an appropriate solution to the 

problem under consideration. The end result of this stage is a broad overview 

of the sequence of operations that are to be carries out to solve the given 

problem. 
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3. Developing the solution: Here the overview of the sequence of operations 

that was the result of analysis stage is expanded to form a detailed step by step 

solution to the problem under consideration. 

4. Coding and implementation: The last stage of the problem solving is the 

conversion of the detailed sequence of operations in to a language that the 

computer can understand. Here each step is converted to its equivalent 

instruction or instructions in the computer language that has been chosen for 

the implantation. 

4.6. Algorithms 

A set of sequential steps usually written in Ordinary Language to solve a 

given problem is called Algorithm. 

 It may be possible to solve to problem in more than one ways, resulting in 

more than one algorithm. The choice of various algorithms depends on the 

factors like reliability, accuracy and easy to modify. The most important 

factor in the choice of algorithm is the time requirement to execute it, after 

writing code in High-level language with the help of a computer. The 

algorithm which will need the least time when executed is considered the best. 

 Steps involved in algorithm development An algorithm can be defined as “a 

complete, unambiguous, finite number of logical steps for solving a specific 

problem“. 

 Step1: Identification of input: For an algorithm, there are quantities to be 

supplied called input and these are fed externally. The input is to be 

indentified first for any specified problem.  

Step2: Identification of output: From an algorithm, at least one quantity is 

produced, called for any specified problem.  
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Step3 : Identification the processing operations : All the calculations to be 

performed in order to lead to output from the input are to be identified in an 

orderly manner.  

Step4 : Processing Definiteness : The instructions composing the algorithm 

must be clear and there should not be any ambiguity in them. 

Step5 : Processing Finiteness : If we go through the algorithm, then for all 

cases, the algorithm should terminate after a finite number of steps.  

Step6 : Possessing Effectiveness : The instructions in the algorithm must be 

sufficiently basic and in practice they can be carries out easily. 

 An algorithm must possess the following properties 

 1. Finiteness: An algorithm must terminate in a finite number of steps 

 2. Definiteness: Each step of the algorithm must be precisely and 

unambiguously stated  

3. Effectiveness: Each step must be effective, in the sense that it should be 

primitive easily convert able into program statement) can be performed 

exactly in a finite amount of time.  

4. Generality: The algorithm must be complete in itself so that it can be used 

to solve problems of a specific type for any input data. 

 5. Input/output: Each algorithm must take zero, one or more quantities as 

input data produce one or more output values. An algorithm can be written in 

English like sentences or in any standard representation sometimes, algorithm 

written in English like languages are called Pseudo Code. 

 

Example 1. Suppose we want to find the average of three numbers? 

The algorithm is as follows  
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Step 1 Read the numbers a, b, c  

Step 2 Compute the sum of a, b and c  

Step 3 Divide the sum by 3  

Step 4 Store the result in variable d  

Step 5 Print the value of d  

Step 6 End of the program 

 

4.7. Flowchart 

A flow chart is a step by step diagrammatic representation of the logic paths to 

solve a given problem. Or a flowchart is visual or graphical representation of 

an algorithm. The flowcharts are pictorial representation of the methods to b 

used to solve a given problem and help a great deal to analyze the problem 

and plan its solution in a systematic and orderly manner. A flowchart when 

translated in to a proper computer language, results in a complete program. 

Advantages of Flowcharts 

1. The flowchart shows the logic of a problem displayed in pictorial fashion 

which felicitates easier checking of an algorithm. 

 2. The Flowchart is good means of communication to other users. It is also a 

compact means of recording an algorithm solution to a problem.  

3. The flowchart allows the problem solver to break the problem into parts. 

These parts can be connected to make master chart.  

4. The flowchart is a permanent record of the solution which can be consulted 

at a later time.  

Differences between Algorithm and Flowchart 
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Algorithms Flowchart 

1. A method of representing the step-

by-step logical procedure for solving a 

problem 

2.It contains step-by-step English 

descriptions, each step representing a 

particular operation leading to solution 

of problem  

3. These are particularly useful for small 

problems 4. For complex programs, 

algorithms prove to be Inadequate 

1. Flowchart is diagrammatic 

representation of an algorithm. It is 

constructed using different types of 

boxes and symbols. 

2. The flowchart employs a series of 

blocks and arrows, each of which 

represents a particular step in an 

algorithm  

3. These are useful for detailed 

representations of complicated programs 

 4. For complex programs, Flowcharts 

prove to be adequate 

4.7.1. Symbols used in flowcharts 

The symbols that we make use while drawing flowcharts as given below are 

as per conventions followed by International Standard Organization (ISO).  

a. Oval: Rectangle with rounded sides is used to indicate either START/ 

STOP of the program. .. 

 

 b. Input and output indicators: Parallelograms are used to represent input 

and output operations. Statements like INPUT, READ and PRINT are 

represented in these Parallelograms. 
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 c. Process Indicators:  Rectangle is used to indicate any set of processing 

operation such as for storing arithmetic operations. 

 

d. Decision Makers: The diamond is used for indicating the step of decision 

making and therefore known as decision box. Decision boxes are used to test 

the conditions or ask questions and depending upon the answers, the 

appropriate actions are taken by the computer. The decision box symbol is 

 

 

 e. Flow Lines: Flow lines indicate the direction being followed in the 

flowchart. In a Flowchart, every line must have an arrow on it to indicate the 

direction. The arrows may be in any direction  

 

 

 

 

f. On- Page connectors: Circles are used to join the different parts of a 

flowchart and these circles are called on-page connectors. The uses of these 

connectors give a neat shape to the flowcharts. Ina complicated problems, a 

flowchart may run in to several pages. The parts of the flowchart on different 

pages are to be joined with each other. The parts to be joined are indicated by 

the circle. 
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 g. Off-page connectors: This connector represents a break in the path of 

flowchart which is too large to fit on a single page. It is similar to on-page 

connector. The connector symbol marks where the algorithm ends on the first 

page and where it continues on the second. 

 

 

Simple problem using flow chart 

 

 

The above flowchart explains about sum of two numbers. 
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4.8. Summary 

 Steps to AutoFit Columns: 
 Click on Column Header/or any other cell in the column to change 

its width. 
 Click Home tab. 
 Select format from the cells group on the ribbon. 
 Click on AutoFit Column Width. 

 In Microsoft Excel, a chart is often called a graph. It is a visual 
representation of data from a worksheet that can bring more 
understanding to the data than just looking at the numbers. 

 A set of sequential steps usually written in Ordinary Language to solve 
a given problem is called Algorithm 

 The flowcharts are pictorial representation of the methods to b used to 
solve a given problem and help a great deal to analyze the problem and 
plan its solution in a systematic and orderly manner. 

4.9. SAQ 

1. Write a short note on functions in Excel? 

2. Define Algorithm  

3. What is Flowchart? 

4. What are the symbols of Flowchart ? 

5. Write an Algorithm for perimeter of Triangle ? 

6.  What are the basic steps involved In problem solving? 

7. Differentiate between Algorithm and Flowchart. 

8. Write an algorithm to find greatest of given three numbers. 

 

 
  
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